Warning! Owners of A5 / A5X Devices Should Stay Away From iOS 5.1.1

iOS 5.1.1 Warning
A few hours ago, Apple released iOS 5.1.1 firmware. This new update doesn’t show up to bring any new functions, but it does contain a important bug fixes and otherchanges.

Previously we confirmed that A4 devices on iOS 5.1.1 firmware can be jailbroken — that doesn't mean you need to update to iOS 5.1.1

Actually, all users having an A5 / A5X device should stay away from iOS 5.1.1. The popular Dev Team member — MuscleNerd posted a warning via Twitter, informing jailbreakers having an iPad 2 / 3 or an iPhone 4S to stay away from the iOS 5.1.1.
iPad 2, iPad 3, iPhone 4S iOS 5.1.1
MuscleNerd Warning Status
A few days ago we announced that pod2g is making excellent progress with the iOS 5.1 untethered jailbreak, and upgrading to iOS 5.1.1 can kill your possibilities of using it. All non-A5 device owners are welcome to upgrade their devices because iOS 5.1.1 is successfully jailbroken.

Keep in mind that iOS 5.1.1 jailbreak is still tethered!
| May 07, 2012 Related Topics: A5, A5X, news